解决vue2中使用elementUi打包报错的问题

解决vue2中使用elementUi打包报错的问题

bug1.找不到element-ui/lib/theme-default/index.css

解决:修改路径为 element-ui/lib/theme-chalk/index.css

原因:elementUi升级时遗留bug

bug2: ERROR in static/js/app.77ab8a3664d32f2b9c76.js from UglifyJs

Unexpected token: operator (>) [./~/element-ui/src/mixins/emitter.js:2,0][assets/js/0.498ce690b229694d8858.js:3947,32

解决:打开build目录下webpack.base.conf.js文件

添加

{
 test: /.js$/i,
 loader: "babel-loader",
 include: [
  resolve("src"),
  resolve("test"),
  resolve("node_modules/element-ui/src/mixins/emitter.js"),
 ],
},

若重复build不断有类似错误,添加

 test: /.js$/i,
 loader: "babel-loader",
 include: [
  resolve("src"),
  resolve("test"),
  resolve("node_modules/element-ui/src"),
  resolve("node_modules/element-ui/packages")
 ],
},

补充知识:vue脚手架加载element-ui报错的解决方法

引入 import "element-ui/lib/theme-chalk/index.css" 后

各种报错,解决方法

1、cnpm install css-loader style-loader file-loader -D

2、 在webpack.config.js中增加一行rules

{test: /.(eot|woff|ttf)$/, loader: "file-loader" }

3、npm run dev

注意: {test: /.css$/,loader: "style-loader!css-loader"}这一行不必添加,我加上这一行后反而运行错误,这样写也不行 {test: /.css$/,loader: "style!css"}

以上这篇解决vue2中使用elementUi打包报错的问题就是小编分享给大家的全部内容了,希望能给大家一个参考,也希望大家多多支持云海天教程。

原文链接:https://blog.csdn.net/Toury_J/article/details/80926767