Android Studio升级到4.1以后插件问题解决

当把Android Studio升级到4.1以后插件提示不可用,然后启动的报下面的错:

在这里插入图片描述

错误的意思是该插件只支持IDEA,然后想把这个插件删除,发现在已安装的插件中是找不到这个插件的,如下:

在这里插入图片描述

然后发现需要安装:

在这里插入图片描述

然后就进入了死循环,启动的时候提示已经安装,但是无法使用,报错,删除的时候提示没有安装,无法删除。

解决办法:

找到Android Studio的插件安装路径,然后删除该插件的安装包或者jar文件即可。
路径一般为:C:UsersuserNameAppDataRoamingGoogleAndroidStudio4.1plugins

在这里插入图片描述

删除完成以后重启Android Studio就不再报错了!

android studio报java.lang.NoSuchMethodError: com.intellij.ide.plugins.PluginManagerCore解决办法

插件跟不上版本的原因。
windows下解决办法
 打开as,保持出错页面不要点确定
C:Users(用户){pc_use_name}AppDataRoamingGoogleAndroidStudio4.1plugins
 AppData为隐藏目录
AndroidStudio4.1可能是其他版本这个无所谓,目录下面所有文件压缩,完成后全选删除,删除不了的就是那个出错的jar。记录一下。
as里点确认,关闭错误提示。
 解压缩,然后手动删除出错的文件。重新打开as

另一个插件目录为
C:Users{pc_use_name.AndroidStudio3.5configplugins

到此这篇关于Android Studio升级到4.1以后插件问题解决的文章就介绍到这了,更多相关Android Studio4.1插件内容请搜索云海天教程以前的文章或继续浏览下面的相关文章希望大家以后多多支持云海天教程!

原文链接:https://blog.csdn.net/qq_22783769/article/details/109093396