Linux下安装软件包报依赖等相关问题的解决方法

背景

在内网服务器下无法利用yum进行安装,需要自行安装可能会出现相关依赖报错(依赖软件包版本不兼容)的情况出现,解决思路:可以找一台相同操作系统版本且支持yum下,通过已安装的软件包拷贝到另一台机器上进行安装。

1)开启 yum 的 keepchche 功能:方法1

vi /etc/yum.conf  
	keepcache =1  		# 修改为1	

在这里插入图片描述

例:安装 iptables

yum -y install iptables iptables-services  
cd /var/cache/yum/x86_64/7
ls     

如图片显示:iptables的源在base目录下

在这里插入图片描述

cd packages/ 
ls

根据/etc/yum.conf 配置文件的cachedir 设置的路径查看,刚 yum安装的 iptables 软件保存在 packages/下

在这里插入图片描述

2) yum-utils 软件:方法2

# 安装yum-utils软件,--destdir指定目录, 最后面指定需要安装的包名
yumdownloader --destdir=/root iptables iptables-services
cd /root
ls

在这里插入图片描述

3) lrzsz 下载上传

yum -y install lrzsz
# rz保存到本地/ sz上传到服务器

在这里插入图片描述

到此这篇关于Linux下安装软件包报依赖等相关问题的解决方法的文章就介绍到这了,更多相关Linux报依赖问题内容请搜索云海天教程以前的文章或继续浏览下面的相关文章希望大家以后多多支持云海天教程!