[Linux] 解决CentOS下Requires: libjson-c.so错误

当安装某些rpm包的时候 , 会爆出这个错误

Requires: libjson-c.so

json-c是c语言下的json库 , 如果在centos6下可以访问下面这个页面找到64位的rpm包 , 一定要看清是4位还是32位

http://rpmfind.net/linux/rpm2html/search.php?query=libjson-c.so.2()(64bit)

 

下载rpm包 ,  并且安装它

wget http://rpmfind.net/linux/centos/6.10/os/x86_64/Packages/json-c-0.11-13.el6.x86_64.rpm

rpm -Uvh json-c-0.11-13.el6.x86_64.rpm