在IDEA已经设置了JDK1.8,但还是用JDK1.7编译。

此时有可能是由于使用了maven来构建项目,其中的配置还是JDK1.7,更改为以下配置

<properties>
    <java.version>1.8</java.version>
</properties>